Problema ao Atualizar Yarn com NVM e HomeBrew


Olá 🙂

Uso o HomeBrew pra facilitar a instalação de pacotes no MacOS.

Hoje (28/07/2017) fui tentar atualizar o Yarn que estava na versão 0.24.*, para a versão 0.25.1 no momento, e a dependência dele é o NodeJS 8.2.*, eu já uso o NodeJS 8.2 com o NVM, mas o HomeBrew não reconhecia, a forma de resolver o problema foi:

  • Desinstalar o Yarn do Homebrew
  • Instalar novamente usando a flag:
    — ignore-dependencies

Usando o brew uninstall –force yarn, desinstala todas as versões de Yarn encontradas no sistema, e o brew install yarn –ignore-dependencies, instala sem tentar instalar a dependência atual do Yarn que é o NodeJS 8.2, que eu já tenho instalado via NVM usando como default.

Pessoal, é isso, vou tentar registrar os acontecidos do dia-a-dia com mais frequência, até a próxima.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *